Голосовой ввод в мобильном приложении 1С

Пример распознавания голоса в мобильном приложении на 1С.

Для примера создадим обработку и на форме разместим таблицу с одной колонкой «Номенклатура». Тип Строка.

Добавим команду «Старт» со следующим кодом:

&НаКлиенте
Процедура Старт(Команда)
	#Если МобильноеПриложениеКлиент Тогда
	Запуск = Новый ЗапускПриложенияМобильногоУстройства("android.speech.action.RECOGNIZE_SPEECH");
	//установим заголовок
	Запуск.ДополнительныеДанные.Добавить("android.speech.extra.PROMPT", "Говорите...");
 
	//работает только на Android
	Если Запуск.ПоддерживаетсяЗапуск() Тогда
		//в случае ошибки вернет 0
		Если Запуск.Запустить(Истина) <> 0 Тогда
			//получим текст
			Результат = Запуск.ДополнительныеДанные.Получить("query").Значение;
			//добавим новую строку
			НовСтр = Товары.Добавить();
			НовСтр.Номенклатура = Результат;
			//запустим еще раз
			Старт(Элементы.ФормаСтарт);
		КонецЕсли;	
	Иначе
		Сообщить("Распознование голоса не поддерживается!");
	КонецЕсли;	
	#КонецЕсли
КонецПроцедуры

Запустим приложении, откроем форму обработки и нажмем «Старт». Продиктуем подряд несколько наименований товаров. В результате получится следующее:

Дополнительно можно сделать поиск номенклатуры в справочнике по наименованию. Или выгружать строкой в основную конфигурацию, а уже там выполнять поиск.

Рейтинг
( Пока оценок нет )
Понравилась статья? Поделиться с друзьями: