Оператор безусловного перехода Перейти в 1С 8.3

Курс

Оператор безусловного перехода Перейти в 1С это аналог goto в других языках программирования. Данный оператор позволяет безусловно передать управление на другой оператор.

Оператор Перейти не может передать управление за пределы программного модуля, процедуры или функции. А также не может передать управление на оператор, который находится внутри конструкций Если — КонецЕсли, Для — КонецЦикла, Пока — КонецЦикла, ДляКаждого — КонецЦикла, Попытка — КонецПопытки.

После ключевого слова Перейти нужно указать имя метки. Имя метки всегда начинается со знака «~». В строке, куда будет осуществлен переход, после имени метки ставится двоеточие «:». Например:

После выполнения данного кода переменная «а» будет равна 2, а переменная «б» равна 1. Так произошло, потому что мы «перепрыгнули» через строку кода «б = б + 1;», когда дошли до оператора Перейти.

Имя метки может быть произвольным, но должно удовлетворять правилам названия переменных.

Если попытаться сделать так:

То при компиляции будет ошибка «На метку с указанным именем имеется недопустимый переход (~Метка)», потому что нельзя переходить внутрь конструкции Для — КонецЦикла.

Не рекомендуется использовать оператор безусловного перехода в программном коде. Как правило задачу можно решить и без него.


Подписывайтесь на группу ВКонтакте , где я публикую ссылки на новые статьи с данного сайта, а также интересные материалы с других ресурсов по программированию в 1С
Понравилась статья? Поделиться с друзьями:
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!:

Используя этот сайт, Вы даете согласие на использование cookies. На данном этапе Вы можете отказаться от использования cookies, настроив необходимые параметры в своем браузере.
ok