Условные конструкции в 1С

Условные конструкции позволяют направить работу программного кода по разным путям, в зависимости от условия.

Конструкция Если … Тогда…КонецЕсли

Данная конструкция проверяет истинность условия. В зависимости от результата будет или не будет выполнен код из блока Если…Тогда…КонецЕсли

После ключевого слова Если находится условие. Если условие истинно, то будет выполнен код, размещенный в блоке Если…Тогда…КонецЕсли. В примере выше условие истинно, поэтому переменная «а» будет увеличена на единицу.

Если нужно чтобы при несоблюдении условия тоже выполнялся какой-то код, то нужно добавить блок Иначе:

Можно добавить дополнительные блоки ИначеЕсли:

С помощью логических операторов можно объединить несколько условий:

В отличии от других языков программирования, в 1С нет конструкции switch/case.

Тернарный оператор

Тернарный оператор имеет следующий синтаксис: ?(<Условие>, <Выражение1>, <Выражение2>). Если условие истинно, то будет выполнено Выражение1, иначе Выражение2.


Подписывайтесь на группу ВКонтакте , где я публикую ссылки на новые статьи с данного сайта, а также интересные материалы с других ресурсов по программированию в 1С
Понравилась статья? Поделиться с друзьями:
Используя этот сайт, Вы даете согласие на использование cookies. На данном этапе Вы можете отказаться от использования cookies, настроив необходимые параметры в своем браузере.
ok